VMware vROPS: Upgrade von 6.3 auf 6.4 schlägt fehl

18. November 2016 at 13:03
vROPS

vROPS

Am 15. November 2016 veröffentlichte VMware eine neue Version von VMware vRealize Operations Manager 6.4 (kurz: vROPS) mit Verbesserungen, neuen Dashboards und auch eine Unterstützung für das ebenfalls neue vSphere 6.5. Genaueren Release Notes finden sich hier.

Neugierig wie ich bin, wollte ich gleich meine vROPS-Installation von 6.3.0 auf 6.4.0 aktualisieren. Leider schlägt schon die Aktualisierung des Betriebssystems der virtuellen Appliance fehl. Zwar mit dem – relativ wenig aussagenden – Fehler:

Failed - upgrade.pak.failed.casa_orchestrator

VA-OS 6.4 Upgrade Fails

VA-OS 6.4 Upgrade Fails

Im Netz lässt sich leider kaum etwas dazu finden. Auch die „Pre-Update System Validation“ meldet keinerlei Fehler – alles sei in Ordnung. Die abgebrochene Update-Installation sagt aber etwas anderes.

Weiterlesen…

[QuickTipp] phpMyAdmin Update-Script

12. September 2014 at 13:00

Weil ich mir selten genügend Zeit nehme immer phpMyAdmin auf dem aktuellsten Stand zu halten, weil oft Updates veröffentlicht werden, kann ich an dieser Stelle ein kleines Bash-Script empfehlen, was die Aufgabe eindeutig einfacher gestaltet. Das – im Grunde einfache – Script aktualisiert einfach phpMyAdmin – mehr nicht, das aber dafür einwandfrei und zuverlässig. Die Einrichtung ist dabei auch sehr einfach.

Die ultimative Kombination, wie ich es aktuell im Einsatz habe, ist es dass Script über einen Cronjob automatisiert ausführen zu lassen. So wird mein phpMyAdmin immer stets aktuell gehalten, ohne jedesmal irgendwie selbst eingreifen zu müssen. Die Aktualisierung erfolgt natürlich auch nur dann, wenn es eine neuere Version als die derzeit installierte Version gibt.

Einrichtung des Scripts

cd /opt # Verzeichnis zu /opt wechseln
wget https://raw.githubusercontent.com/stefansl/pma-updatescript/master/pma-update.sh # Download
chmod +x pma-update.sh # Ausführrechte vergeben
nano pma-update.sh # Script bearbeiten und Variablen anpassen

Im Anschluss einfach die Variablen, die in der Datei genauer erläutert werden, anpassen und die Datei abspeichern. Die Ausführung erfolgt dann einfach mit ./pma-update.sh – oder aber mit ./pma-update.sh 3.5.0, um auf eine spezielle Version zu wechseln.

Einrichtung des Cronjobs
Die Zeile für den Cronjob (crontab -e) kann zum Beispiel wie folgt lauten:

30 4 * * * cd /opt/ && bash pma-update.sh >> /var/log/pma-update.log

In diesem Fall wird das Update-Script täglich um 04:30 Uhr ausgeführt und aktualisiert automatisch phpMyAdmin, falls es eine neuere Version geben sollte.

Das Script lässt sich auf GitHub unter github.com/stefansl/pma-updatescript finden.

Ein großer Dank für die Empfehlung des Scripts geht an php-friends.de! 🙂

Linux: OpenSSL auf Debian Squeeze auf die aktuellste Version aktualisieren

2. April 2013 at 13:37

Einige Programme, Dienste oder Funktionen benötigen teilweise eine aktuellere Version von OpenSSL. Nur sind leider die offiziellen Debian Repositories etwas langsamer bei den Updates, dagegen sind diese immer stabil. Manchmal kommt man aber nicht herum, einige Programme selbst zu compilieren, um die neueren Funktionen nutzen zu können.

OpenSSL

Weiterlesen…

Top